Data not passing from subassembly as expected

Currently working on something and have a question.

One of the last steps in an assembly is using the Data Rows – Loop module to loop through a series of xml nodes. each node is sent to a subassembly that uses that data to build a completely new xml node. That new node is returned and the loop module is emitting the results as a new data stream.

As I believe it should work is that will leave me with the original xml data stream and a new data stream consisting of the returned values.

When I test the subassembly it shows the new xml as it should be. When I run that sub within the data row loop it doesn’t kick anything out. No errors or anything. Just the original stream and no new stream.

I have also tried to append the results to a “TEST” node within the original. TEST will show up but no data in it.

I assume something is happening with the handoff between the two but not sure exactly what the disconnect is.

Any ideas would be helpful

The problem is likely to be the data emitted by the Subassembly Output module.

Experiment by hardcoding different output values, e.g. use the Data Streams - Create from Text module to make a simple output stream, wire it to the Subassembly Output and see how the Loop handles the results.

1 Like

Nevermind the reply.

Answered my own follow up question

Having any luck with the troubleshooting?

Unfortunately no.
Here is what I tried

If I wire the datastream to the subassembly output it returns nothing.
If I copy that output to a text value and wire that to the sub out then it will push the data as expected.

What i have is this
input xml. data stream split to two data row loops. each loop has xml builder inside, one creating a header row one creating a detail row. each emitting results as a new data stream. both coming together with data stream merge. subassembly output

The output of the merge is good but when i wire that to the output i get nothing. Copy the merge output and paste that into a text value and it works. Really not sure what is the issue

Hi Brent,

I have created a sample assembly in your system. The looped subass emits a data stream and the loop creates a new data stream containing the results for all iterations. Seems to be similar to what you are trying to do and works ok for me.

Search for assembly a41f7d8266394de3865952e041819d85 in your catalog and take a look.

The data row loop is similar to what I am running. The issue i believe is in the subassembly.
If I wire text data to the out, it work. if i wire the xml stream, doesnt.
If you would like to look at it, it is TEXON pass through.

I am sure being new I am missing something minor but I don’t know everything yet.

Which parent assembly is using that subass? I did a search and don’t see the subass being used anywhere.

Sage intacct action


Any luck finding the issue?

When I run the action assembly no data is fetched, so nothing happens.

I need a standalone test case that doesn’t fetch any data from the API.

I was working on something else and changed the default credentials for intacct. it is now good to go and the default info in there should pull back results now

I have modified the parent action assembly to be a test case without API calls.

When I run the parent assembly on the server, the Loop appears to work as expected:

So it seems you have found a problem just in the browser runtime.

I am just starting to troubleshoot that. Please don’t touch these 2 assemblies until I find and fix the problem.

Wont touch a thing


Hi Brent,

I finally have the issue fixed. I have undone the test changes to the assemblies and they seem to work ok for me in the browser now.

You need to clear your browser cache and reload the assembly editor to get the patch.

Sorry for the trouble! I know it probably drove you crazy trying to figure out why it wasn’t working as it seemingly should.


Yeah. i figured it was just something small i was missing. Guess i was ok.

Ok that seems to be working great now. Thanks for that.

One last follow up question. I can see the action for generate CSV under transform text. Am I correct that this only converts the text to csv but doesnt write it to a file? If so, what would be the best way after that to write it to a file to be emailed out?


Please keep forum threads to a single topic. Start a new topic for the question, thanks.